Android requires compiler compliance level 5.0 or 6.0. Found ‘1.7’ instead. Please use Android Tools > Fix Project Properties

That isn’t the problem, Jack. Android SDK isn’t x64, but works ok with x64 jvm (and x64 eclipse IDE).

As helios said, you must set project compatibility to Java 5.0 or Java 6.0.

To do that, 2 options:

  1. Right-click on your project and select "Android Tools -> Fix
    Project Properties"
    (if this din’t work, try second option)
  2. Right-click on your project and select "Properties -> Java
    , check “Enable project specific settings” and select
    1.5 or 1.6 from “Compiler compliance settings” select box.

Leave a Comment