The abbreviation impl is used in a lot of libraries; What does it mean? [closed]

It stands for Implementation. It’s a Java convention. Often in java (particularly J2EE) you will get an object from some factory, and then use it. That object’s type is often given to you as an interface, so that you don’t need to know the actual class, just its methods. An impl class is usually a … Read more

Naming convention and structure for utility classes and methods

I believe there is a continuum of complexity, therefore corresponding organizations. Examples follow, choose depending of the complexity of your project and your utilities, and adapt to other constraints : One class (called Helper), with a few methods One package (called helper), with a few classes (called XXXHelper), each class with a few methods. Alternatively, … Read more

Object persistence terminology: ‘repository’ vs. ‘store’ vs. ‘context’ vs. ‘retriever’ vs. (…)

As noone has yet answered the question, I’ll post on what I have decided in the meantime. Just for the record, I have pretty much decided on calling most data store classes repositories. First, it appears to be the most neutral, non-technical term from the list I suggested, and it seems to be well in … Read more

Swift: Global constant naming convention?

Swift 3 API guidelines state that “Names of types and protocols are UpperCamelCase. Everything else is lowerCamelCase.” https://swift.org/documentation/api-design-guidelines/ Ideally your global constants will be located within an enum, extension, or struct of some sort, which would be UpperCamelCase, and all properties in that space would be lowerCamelCase. struct LoginConstants { static let maxAttempts = 10 … Read more